Back to overview
Resolved
Reverting to backup due to an accidental clear
Aug 30, 2026 at 2:47am UTC
Affected services
Website
Competitions
Practice
Database
Resolved
Aug 30, 2026 at 2:52am UTC
The picks have been restored from backup and flexSO is working normally.
Affected services
Created
Aug 30, 2026 at 2:47am UTC
Reverting to backup due to an accidental clear.
Affected services